Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2023-30967: Gotham Orbital-Simulator service prior to 0.692.0 was found to be vulnerable to a Path traversal issue allowing an unauthenticated user to read arbitrary files on the file system.

CVE-2023-30967 · published 3 years ago
Summary

Gotham Orbital-Simulator service prior to 0.692.0 was found to be vulnerable to a Path traversal issue allowing an unauthenticated user to read arbitrary files on the file system.

What to do
  • Update palantir orbital_simulator to version 0.692.0 or later.
Affected software
VendorProductAffected versions
palantir orbital_simulator < 0.692.0
cpe:2.3:a:palantir:orbital_simulator:*:*:*:*:*:*:*:*
Original advisory text
Gotham Orbital-Simulator service prior to 0.692.0 was found to be vulnerable to a Path traversal issue allowing an unauthenticated user to read arbitrary files on the file system.
Gotham Orbital-Simulator service prior to 0.692.0 was found to be vulnerable to a Path traversal issue allowing an unauthenticated user to read arbitrary files on the file system.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker partial control
Severity
7.5 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-22Path Traversal
CWE-287Improper Authentication
Timeline
Published26 Oct 2023
Updated4 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta