Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.8

CVE-2023-29320: Adobe Acrobat Reader versions 23.003.20244 (and earlier) and 20.005.30467 (and earlier) are affected by an Violation of Secure Design Principles vulnerability that could result in arbitrary code ex...

CVE-2023-29320 · published 3 years ago
Summary

Adobe Acrobat Reader versions 23.003.20244 (and earlier) and 20.005.30467 (and earlier) are affected by an Violation of Secure Design Principles vulnerability that could result in arbitrary code execution in the context of the current user by bypassing the API blacklisting feature. Exploitation of t...

What to do
  • Update adobe acrobat_dc to version 23.003.20269 or later.
  • Update adobe acrobat_reader_dc to version 23.003.20269 or later.
Affected software
VendorProductAffected versions
adobe acrobat_dc >= 15.008.20082, < 23.003.20269
cpe:2.3:a:adobe:acrobat_dc:*:*:*:*:continuous:*:*:*
adobe acrobat_reader_dc >= 15.008.20082, < 23.003.20269
cpe:2.3:a:adobe:acrobat_reader_dc:*:*:*:*:continuous:*:*:*
adobe acrobat >= 20.001.30005, <= 20.005.30516.10516
>= 20.001.30005, < 20.005.30514.10514
cpe:2.3:a:adobe:acrobat:*:*:*:*:classic:*:*:*
adobe acrobat_reader >= 20.001.30005, < 20.005.30516.10516
>= 20.001.30005, < 20.005.30514.10514
cpe:2.3:a:adobe:acrobat_reader:*:*:*:*:classic:*:*:*
Original advisory text
Adobe Acrobat Reader versions 23.003.20244 (and earlier) and 20.005.30467 (and earlier) are affected by an Violation of Secure Design Principles vulnerability that could result in arbitrary code ex...
Adobe Acrobat Reader versions 23.003.20244 (and earlier) and 20.005.30467 (and earlier) are affected by an Violation of Secure Design Principles vulnerability that could result in arbitrary code execution in the context of the current user by bypassing the API blacklisting feature. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
References
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
7.8 High
Exploitation
6% chance of attack within 30 days
Type
CWE-657Violation of Secure Design Principles
Timeline
Published10 Aug 2023
Updated1 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta