Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2023-2705: The gAppointments WordPress plugin before 1.10.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used agai...
CVE-2023-2705 · published 3 years ago
Summary
The gAppointments WordPress plugin before 1.10.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against admin
What to do
- Update gappointments gappointments to version 1.10.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| gappointments | gappointments |
< 1.10.0 cpe:2.3:a:gappointments:gappointments:*:*:*:*:*:wordpress:*:* |
Original advisory text
The gAppointments WordPress plugin before 1.10.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used agai...
The gAppointments WordPress plugin before 1.10.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against admin
References
- https://wpscan.com/vulnerability/0b3c83ad-d490-4ca3-8589-39163ea5e24b Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Timeline
Published11 Sep 2023
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2023-2705 · NVD
Track software like this
Free during beta