Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2023-25167: Regular expression denial of service via installing themes via git in discourse

CVE-2023-25167 · published 3 years ago
Summary

Discourse is an open source discussion platform. In affected versions a malicious user can cause a regular expression denial of service using a carefully crafted git URL. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. There are ...

What to do
  • Update discourse discourse to version 3.0.1 or later.
Affected software
VendorProductAffected versions
discourse discourse < 3.0.1
3.1.0
cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*
Original advisory text
Regular expression denial of service via installing themes via git in discourse
Discourse is an open source discussion platform. In affected versions a malicious user can cause a regular expression denial of service using a carefully crafted git URL. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. There are no known workarounds for this issue.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-1333Inefficient Regular Expression Complexity (ReDoS)
Timeline
Published8 Feb 2023
Updated4 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta