Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.1

CVE-2023-1270: Cross-site Scripting in btcpayserver/btcpayserver

CVE-2023-1270 · published 3 years ago
Summary

Cross-site Scripting in GitHub repository btcpayserver/btcpayserver prior to 1.8.3.

What to do
  • Update btcpayserver btcpayserver to version 1.8.3 or later.
Affected software
VendorProductAffected versions
btcpayserver btcpayserver < 1.8.3
cpe:2.3:a:btcpayserver:btcpayserver:*:*:*:*:*:*:*:*
Original advisory text
Cross-site Scripting in btcpayserver/btcpayserver
Cross-site Scripting in GitHub repository btcpayserver/btcpayserver prior to 1.8.3.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
5.1 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published8 Mar 2023
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2023-1270 · NVD
CVE-2023-1270 · OSV
Track software like this
Free during beta