Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.0

CVE-2023-0741: Answer platform lets attackers inject malicious scripts

CVE-2023-0741 · published 3 years ago
Summary

The Answer open‑source Q&A software (versions before 1.0.4) contains a client‑side scripting flaw that lets a malicious user place harmful code into web pages. This could let the attacker steal user data, hijack sessions, or display unwanted content. Update the software to version 1.0.4 or later, or apply the recommended code changes, to close the risk.

What to do
  • Update github.com answerdev to version 1.0.4.
  • Update answer answer to version 1.0.4 or later.
Affected software
Ecosystem VendorProductAffected versions
go github.com answerdev < 1.0.4
Fix: upgrade to 1.0.4
– answer answer < 1.0.4
cpe:2.3:a:answer:answer:*:*:*:*:*:*:*:*
Original advisory text
Cross-site Scripting (XSS) - DOM in answerdev/answer
Cross-site Scripting (XSS) - DOM in GitHub repository answerdev/answer prior to 1.0.4.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
8.0 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published8 Feb 2023
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2023-0741 · NVD
CVE-2023-0741 · OSV
Track software like this
Free during beta