Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.8

CVE-2023-0358: Gpac Software Uses Memory After It's Freed

CVE-2023-0358 · published 3 years ago
Summary

The gpac software is vulnerable to a memory safety issue that could allow an attacker to execute malicious code. This issue affects versions of gpac prior to 2.3.0-DEV, which means users of those versions should update to the latest version to stay secure. Update gpac to version 2.3.0-DEV or later to fix this issue.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
gpac gpac <= 2.2.0
cpe:2.3:a:gpac:gpac:*:*:*:*:*:*:*:*
Original advisory text
Use After Free in gpac/gpac
Use After Free in GitHub repository gpac/gpac prior to 2.3.0-DEV.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
7.8 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-416Use After Free
Timeline
Published18 Jan 2023
Updated4 Nov 2026
First seen7 Aug 2026
Sources
CVE-2023-0358 · OSV
CVE-2023-0358 · NVD
Track software like this
Free during beta