Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.4

CVE-2023-0299: GitHub Publify before 9.2.10: Malicious Data Injection Possible

CVE-2023-0299 · published 3 years ago
Summary

The GitHub Publify blog platform before version 9.2.10 does not properly validate user input. This means an attacker could potentially inject malicious data into the system. To protect your blog, update to version 9.2.10 or later.

What to do
  • Update matijs van zuijlen publify_core to version 9.2.10.
  • Update publify_project publify to version 9.2.10 or later.
Affected software
Ecosystem VendorProductAffected versions
rubygems matijs van zuijlen publify_core < 9.2.10
Fix: upgrade to 9.2.10
– publify_project publify < 9.2.10
cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:*
Original advisory text
Improper Input Validation in publify/publify
Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
8.4 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-20Improper Input Validation
Timeline
Published14 Jan 2023
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2023-0299 · NVD
CVE-2023-0299 · OSV
Track software like this
Free during beta