Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.1

CVE-2022-49250: Linux kernel may read beyond memory and crash

CVE-2022-49250 · published 1 year ago
Summary

A recent fix in the Linux kernel prevents a piece of audio code from reading data that isn’t there. Without the fix, the system could try to access memory outside its allowed area, potentially causing crashes or instability. Updating the kernel to the latest version resolves the issue.

What to do
  • Update debian linux to version 5.17.3-1.
  • Update linux kernel to version 5.17.2.
Affected software
Ecosystem VendorProductAffected versions
– linux linux_kernel >= 5.12, < 5.15.33
>= 5.16, < 5.16.19
>= 5.17, < 5.17.2
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
Debian:12 debian linux < 5.17.3-1
Fix: upgrade to 5.17.3-1
Linux linux kernel >= 5.17.0, < 5.17.2
Fix: upgrade to 5.17.2
Original advisory text
ASoC: codecs: rx-macro: fix accessing compander for aux
In the Linux kernel, the following vulnerability has been resolved: ASoC: codecs: rx-macro: fix accessing compander for aux AUX interpolator does not have compander, so check before accessing compander data for this. Without this checkan array of out bounds access will be made in comp_enabled[] array.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
7.1 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-125Out-of-bounds Read
Timeline
Published26 Feb 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
Track software like this
Free during beta