Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2022-4751: The Word Balloon WordPress plugin before 4.19.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as ...
CVE-2022-4751 · published 3 years ago
Summary
The Word Balloon WordPress plugin before 4.19.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege u...
What to do
- Update back2nature word_balloon to version 4.19.3 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| back2nature | word_balloon |
< 4.19.3 cpe:2.3:a:back2nature:word_balloon:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Word Balloon WordPress plugin before 4.19.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as ...
The Word Balloon WordPress plugin before 4.19.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
References
- https://wpscan.com/vulnerability/dd5cc04a-042d-402a-ab7a-96aff3d57478 Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Timeline
Published23 Jan 2023
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2022-4751 · NVD
Track software like this
Free during beta