Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.1

CVE-2022-4690: GitHub memos Repository Allows Attacker-Controlled Content

CVE-2022-4690 · published 3 years ago
Summary

A security issue in older versions of the GitHub memos repository allows an attacker to inject malicious code into the system. This could potentially allow attackers to steal sensitive information or take control of user accounts. Update to version 0.9.0 or later to fix this issue.

What to do
  • Update github.com usememos to version 0.9.0.
  • Update usememos memos to version 0.9.0 or later.
Affected software
Ecosystem VendorProductAffected versions
go github.com usememos < 0.9.0
Fix: upgrade to 0.9.0
– usememos memos < 0.9.0
cpe:2.3:a:usememos:memos:*:*:*:*:*:*:*:*
Original advisory text
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.0.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker full control
Severity
7.1 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published23 Dec 2022
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2022-4690 · NVD
CVE-2022-4690 · OSV
Track software like this
Free during beta