Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.8
CVE-2022-45872: iTerm2 before 3.4.18 mishandles a DECRQSS response.
CVE-2022-45872 · published 3 years ago
Summary
iTerm2 before 3.4.18 mishandles a DECRQSS response.
What to do
- Update iterm2 iterm2 to version 3.4.18 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| iterm2 | iterm2 |
< 3.4.18 cpe:2.3:a:iterm2:iterm2:*:*:*:*:*:*:*:* |
Original advisory text
iTerm2 before 3.4.18 mishandles a DECRQSS response.
iTerm2 before 3.4.18 mishandles a DECRQSS response.
References
Internet-facing
3 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically
- Gives an attacker full control
Type
CWE-20Improper Input Validation
Timeline
Published23 Nov 2022
Updated3 Nov 2026
First seen29 Sep 2026
Track software like this
Free during beta