Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2022-41228: Jenkins NS-ND Plugin allows unauthorized web server connections
CVE-2022-41228 · published 4 years ago
Summary
An outdated version of the Jenkins NS-ND Integration Performance Publisher Plugin has a security flaw that lets someone with limited access connect to any web server using their own credentials. This means an attacker could potentially access sensitive information or disrupt operations. Update the plugin to the latest version to fix the issue.
What to do
- Update jenkins io.jenkins.plugins:cavisson-ns-nd-integration to version 4.8.0.130.
- Update jenkins ns-nd_integration_performance_publisher to version 4.8.0.130 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| maven | jenkins | io.jenkins.plugins:cavisson-ns-nd-integration |
<= 4.8.0.129 Fix: upgrade to 4.8.0.130
|
| – | jenkins | ns-nd_integration_performance_publisher |
< 4.8.0.130 cpe:2.3:a:jenkins:ns-nd_integration_performance_publisher:*:*:*:*:*:jenkins:*:* |
Original advisory text
A missing permission check in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers with Overall/Read permissions to connect to an attacker-specified webserv...
A missing permission check in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers with Overall/Read permissions to connect to an attacker-specified webserver using attacker-specified credentials.
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Severity
8.8
High
Type
CWE-862Missing Authorization
Timeline
Published21 Sep 2022
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta