Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2022-38553: Academy Learning Management System Search XSS Vulnerability
CVE-2022-38553 · published 4 years ago
Summary
Academy's Learning Management System search function is affected by a vulnerability that could allow hackers to inject malicious code into users' browsers. This could lead to unauthorized actions or data theft. Update to version 5.9.1 or later to fix this issue.
What to do
- Update creativeitem academy_learning_management_system to version 5.9.1 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| creativeitem | academy_learning_management_system |
< 5.9.1 cpe:2.3:a:creativeitem:academy_learning_management_system:*:*:*:*:*:*:*:* |
Original advisory text
Academy Learning Management System before v5.9.1 was discovered to contain a reflected cross-site scripting (XSS) vulnerability via the Search parameter.
Academy Learning Management System before v5.9.1 was discovered to contain a reflected cross-site scripting (XSS) vulnerability via the Search parameter.
References
- https://demo.creativeitem.com/academy/home/ Product
- https://codecanyon.net/item/academy-course-based-learning-management-system/2270... Product Third Party Advisory
- https://demo.creativeitem.com/academy/home/search?query=%22%3E%3Cscript%3Ealert%...
- https://github.com/4websecurity/CVE-2022-38553/blob/main/README.md Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published26 Sep 2022
Updated31 Oct 2026
First seen5 Jul 2026
Track software like this
Free during beta