Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.4

CVE-2022-37421: Silverstripe CMS through 4.11.0 allows malicious code injection

CVE-2022-37421 · published 3 years ago
Summary

A critical security issue in Silverstripe CMS versions up to 4.11.0 allows attackers to inject malicious code into websites, potentially allowing them to take control of the site or steal user data. This means that hackers could compromise sensitive information and disrupt website functionality. Users should update to the latest version of Silverstripe CMS to fix this issue.

What to do
  • Update silverstripe cms to version 4.11.3.
  • Update silverstripe silverstripe to version 4.11.3 or later.
Affected software
Ecosystem VendorProductAffected versions
composer silverstripe cms >= 4.0.0, < 4.11.3
Fix: upgrade to 4.11.3
– silverstripe silverstripe >= 3.0.0, < 4.11.3
cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:*
Original advisory text
Silverstripe silverstripe/cms through 4.11.0 allows XSS.
Silverstripe silverstripe/cms through 4.11.0 allows XSS.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
5.4 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published23 Nov 2022
Updated3 Nov 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta