Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.2
CVE-2022-3366: The PublishPress Capabilities WordPress plugin before 2.5.2, PublishPress Capabilities Pro WordPress plugin before 2.5.2 unserializes the content of imported files, which could lead to PHP object i...
CVE-2022-3366 · published 4 years ago
Summary
The PublishPress Capabilities WordPress plugin before 2.5.2, PublishPress Capabilities Pro WordPress plugin before 2.5.2 unserializes the content of imported files, which could lead to PHP object injection attacks by administrators, on multisite WordPress configurations. Successful exploitation in t...
What to do
- Update publishpress capabilities to version 2.5.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| publishpress | capabilities |
< 2.5.2 cpe:2.3:a:publishpress:capabilities:*:*:*:*:-:wordpress:*:* |
Original advisory text
The PublishPress Capabilities WordPress plugin before 2.5.2, PublishPress Capabilities Pro WordPress plugin before 2.5.2 unserializes the content of imported files, which could lead to PHP object i...
The PublishPress Capabilities WordPress plugin before 2.5.2, PublishPress Capabilities Pro WordPress plugin before 2.5.2 unserializes the content of imported files, which could lead to PHP object injection attacks by administrators, on multisite WordPress configurations. Successful exploitation in this case requires other plugins with a suitable gadget chain to be present on the site.
References
- https://wpscan.com/vulnerability/72639924-e7a7-4f7d-bd50-015d05ffd4fb Exploit Third Party Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Type
CWE-502Deserialization of Untrusted Data
Timeline
Published31 Oct 2022
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2022-3366 · NVD
Track software like this
Free during beta