Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2022-32209: Rails Sanitizer Allows Malicious HTML in Certain Configurations

CVE-2022-32209 · published 4 years ago
Summary

If you're using a specific configuration of Rails' HTML sanitizer, an attacker could inject malicious content into your website. This is possible if you've allowed certain HTML tags, such as 'select' and 'style', in your application's settings or code. To fix this, you should upgrade to a newer version of Rails or modify your configuration to prevent these tags from being used.

What to do
  • Update rafael mendonça frança rails-html-sanitizer to version 1.4.3.
  • Update debian ruby-rails-html-sanitizer to version 1.4.3-0.1.
  • Update rubyonrails rails_html_sanitizers to version 1.4.3 or later.
Affected software
Ecosystem VendorProductAffected versions
rubygems rafael mendonça frança rails-html-sanitizer < 1.4.3
Fix: upgrade to 1.4.3
– rubyonrails rails_html_sanitizers < 1.4.3
cpe:2.3:a:rubyonrails:rails_html_sanitizers:*:*:*:*:*:rails:*:*
– fedoraproject fedora 35
36
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*
– debian debian_linux 10.0
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
Debian:12 debian ruby-rails-html-sanitizer < 1.4.3-0.1
Fix: upgrade to 1.4.3-0.1
Original advisory text
# Possible XSS Vulnerability in Rails::Html::SanitizerThere is a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer.This vulnerability has been assigned the CVE identi...
# Possible XSS Vulnerability in Rails::Html::SanitizerThere is a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer.This vulnerability has been assigned the CVE identifier CVE-2022-32209.Versions Affected: ALLNot affected: NONEFixed Versions: v1.4.3## ImpactA possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer may allow an attacker to inject content if the application developer has overridden the sanitizer's allowed tags to allow both `select` and `style` elements.Code is only impacted if allowed tags are being overridden. This may be done via application configuration:```ruby# In config/application.rbconfig.action_view.sanitized_allowed_tags = ["select", "style"]```see https://guides.rubyonrails.org/configuring.html#configuring-action-viewOr it may be done with a `:tags` option to the Action View helper `sanitize`:```<%= sanitize @comment.body, tags: ["select", "style"] %>```see https://api.rubyonrails.org/classes/ActionView/Helpers/SanitizeHelper.html#method-i-sanitizeOr it may be done with Rails::Html::SafeListSanitizer directly:```ruby# class-level optionRails::Html::SafeListSanitizer.allowed_tags = ["select", "style"]```or```ruby# instance-level optionRails::Html::SafeListSanitizer.new.sanitize(@article.body, tags: ["select", "style"])```All users overriding the allowed tags by any of the above mechanisms to include both "select" and "style" should either upgrade or use one of the workarounds immediately.## ReleasesThe FIXED releases are available at the normal locations.## WorkaroundsRemove either `select` or `style` from the overridden allowed tags.## CreditsThis vulnerability was responsibly reported by [windshock](https://hackerone.com/windshock?type=user).
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.1 Medium
Exploitation
27% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published24 Jun 2022
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta