Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2022-30599: Moodle Badges Configuration SQL Injection Risk

CVE-2022-30599 · published 4 years ago
Summary

Moodle users who manage badges may be at risk of unauthorized database access. This issue affects the configuration of badge criteria and could allow an attacker to manipulate the database. To protect your system, update to the latest Moodle version or apply the recommended patch.

What to do
  • Update moodle moodle to version 4.0.1.
  • Update moodle moodle to version 3.11.7.
  • Update moodle moodle to version 3.10.11.
  • Update moodle moodle to version 3.9.14.
Affected software
Ecosystem VendorProductAffected versions
composer moodle moodle >= 4.0, < 4.0.1
>= 3.11, < 3.11.7
>= 3.10, < 3.10.11
>= 3.9, < 3.9.14
Fix: upgrade to 4.0.1
– moodle moodle 4.0.0
cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:*
– redhat enterprise_linux 8.0
cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:-:*:*:*
– fedoraproject fedora 34
35
36
cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*
Ubuntu:16.04:LTS canonical moodle All versions
Original advisory text
A flaw was found in moodle where an SQL injection risk was identified in Badges code relating to configuring criteria.
A flaw was found in moodle where an SQL injection risk was identified in Badges code relating to configuring criteria.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
9.8 Critical
Exploitation
1% chance of attack within 30 days
Type
CWE-89SQL Injection
Timeline
Published18 May 2022
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta