Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2022-29485: Cross-site scripting vulnerability in SHIRASAGI v1.0.0 to v1.14.2, and v1.15.0 allows a remote attacker to inject an arbitrary script via unspecified vectors.

CVE-2022-29485 · published 4 years ago
Summary

Cross-site scripting vulnerability in SHIRASAGI v1.0.0 to v1.14.2, and v1.15.0 allows a remote attacker to inject an arbitrary script via unspecified vectors.

What to do
  • Update ss-proj shirasagi to version 1.14.3 or later.
Affected software
VendorProductAffected versions
ss-proj shirasagi >= 1.0.0, < 1.14.3
1.15.0
cpe:2.3:a:ss-proj:shirasagi:*:*:*:*:*:*:*:*
Original advisory text
Cross-site scripting vulnerability in SHIRASAGI v1.0.0 to v1.14.2, and v1.15.0 allows a remote attacker to inject an arbitrary script via unspecified vectors.
Cross-site scripting vulnerability in SHIRASAGI v1.0.0 to v1.14.2, and v1.15.0 allows a remote attacker to inject an arbitrary script via unspecified vectors.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.1 Medium
Exploitation
1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published14 Jun 2022
Updated3 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta