Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2022-27920: libkiwix 10.0.0 and 10.0.1 allows XSS in the built-in webserver functionality via the search suggestions URL parameter. This is fixed in 10.1.0.

CVE-2022-27920 · published 4 years ago
Summary

libkiwix 10.0.0 and 10.0.1 allows XSS in the built-in webserver functionality via the search suggestions URL parameter. This is fixed in 10.1.0.

What to do
  • Update debian libkiwix to version 10.1.0+dfsg-1.
Affected software
Ecosystem VendorProductAffected versions
– kiwix libkiwix 10.0.0
10.0.1
cpe:2.3:a:kiwix:libkiwix:10.0.0:*:*:*:*:*:*:*
– fedoraproject fedora 35
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*
Ubuntu:18.04:LTS canonical libkiwix All versions
Debian:12 debian libkiwix < 10.1.0+dfsg-1
Fix: upgrade to 10.1.0+dfsg-1
Original advisory text
libkiwix 10.0.0 and 10.0.1 allows XSS in the built-in webserver functionality via the search suggestions URL parameter. This is fixed in 10.1.0.
libkiwix 10.0.0 and 10.0.1 allows XSS in the built-in webserver functionality via the search suggestions URL parameter. This is fixed in 10.1.0.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.1 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published25 Mar 2022
Updated3 Nov 2026
First seen29 Sep 2026
Track software like this
Free during beta