Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2022-26533: Alist versions 2.1.0 and below allow unauthorized code execution
CVE-2022-26533 · published 4 years ago
Summary
Alist, a web-based IPA library browser, has a security issue that can allow attackers to inject malicious code on a website. This could lead to unauthorized actions on the system. Update Alist to version 2.1.1 or later to fix this issue.
What to do
- Update github.com xhofe to version 2.1.1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| go | github.com | xhofe |
>= 2.0.10, < 2.1.1 Fix: upgrade to 2.1.1
|
| – | alistgo | alist |
<= 2.1.0 cpe:2.3:a:alistgo:alist:*:*:*:*:*:*:*:* |
Original advisory text
Alist v2.1.0 and below was discovered to contain a cross-site scripting (XSS) vulnerability via /i/:data/ipa.plist.
Alist v2.1.0 and below was discovered to contain a cross-site scripting (XSS) vulnerability via /i/:data/ipa.plist.
References
- https://github.com/Xhofe/alist/commit/6af17e2509a400979420f613fd7f2f9721fdcd6e
- https://github.com/advisories/GHSA-jpj5-hg26-6jgc
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/26xxx/CVE-2022-26533... Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2022-26533 Vendor Advisory
- https://github.com/Xhofe/alist/issues/645 Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published12 Mar 2022
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta