Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.3

CVE-2022-22817: Pillow image library can run malicious code

CVE-2022-22817 · published today
Summary

The Pillow package used for handling images may execute harmful code if it processes a specially crafted picture. This risk affects any system that uses Pillow, such as Python projects or Debian installations. Update Pillow to the latest released version to eliminate the danger.

What to do
  • Update jeffrey 'alex' clark pillow to version 9.0.1.
  • Update debian pillow to version 9.0.0-1.
  • Update pillow to version 8.0.1+aikido.1.
  • Update pillow to version 8.1.2+aikido.1.
  • Update python pillow to version 9.0.1 or later.
Affected software
Ecosystem VendorProductAffected versions
pip jeffrey 'alex' clark pillow < 9.0.1
Fix: upgrade to 9.0.1
– python pillow < 9.0.1
cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:*
– debian debian_linux 9.0
10.0
11.0
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
Debian:12 debian pillow < 9.0.0-1
Fix: upgrade to 9.0.0-1
Root:PyPI – pillow < 8.0.1+aikido.1
< 8.1.2+aikido.1
Fix: upgrade to 8.0.1+aikido.1
Original advisory text
CVE-2022-22817 in pillow - Patched by Root
Root has patched CVE-2022-22817 in the pillow package for Root:PyPI. Multiple fixed versions available.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker full control
Severity
9.3 Critical
Exploitation
3% chance of attack within 30 days
Type
CWE-74Injection
Timeline
Published27 Oct 2026
Updated27 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta