Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.9
CVE-2022-2142: The affected product is vulnerable to a SQL injection with high attack complexity, which may allow an unauthorized attacker to disclose information.
CVE-2022-2142 · published 4 years ago
Summary
The affected product is vulnerable to a SQL injection with high attack complexity, which may allow an unauthorized attacker to disclose information.
What to do
- Update advantech iview to version 5.7.04.6469 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| advantech | iview |
< 5.7.04.6469 cpe:2.3:a:advantech:iview:*:*:*:*:*:*:*:* |
Original advisory text
The affected product is vulnerable to a SQL injection with high attack complexity, which may allow an unauthorized attacker to disclose information.
The affected product is vulnerable to a SQL injection with high attack complexity, which may allow an unauthorized attacker to disclose information.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-179-03 Third Party Advisory US Government Resource
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Type
CWE-89SQL Injection
Timeline
Published22 Jul 2022
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2022-2142 · NVD
Track software like this
Free during beta