Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.6
CVE-2022-1812: Publify can mis‑handle large numbers, leading to errors
CVE-2022-1812 · published 3 years ago
Summary
The core components of Publify (publify_core and the main Publify project) may treat very large numbers incorrectly, causing calculations to give wrong results or the system to stop working. This happens when the software tries to store numbers that are bigger than it can handle. Upgrade to the latest version (9.2.10 or newer) to fix the issue.
What to do
- Update matijs van zuijlen publify_core to version 9.2.10.
- Update publify_project publify to version 9.2.10 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| rubygems | matijs van zuijlen | publify_core |
< 9.2.10 Fix: upgrade to 9.2.10
|
| – | publify_project | publify |
< 9.2.10 cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* |
Original advisory text
Integer Overflow or Wraparound in publify/publify
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.
References
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-20...
- https://github.com/advisories/GHSA-rc42-jghf-vr8f
- https://huntr.dev/bounties/17d86a50-265c-4ec8-9592-0bd909ddc8f3 URL
- https://nvd.nist.gov/vuln/detail/CVE-2022-1812 Vendor Advisory
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/1xxx/CVE-2022-1812.j... Vendor Advisory
- https://github.com/publify/publify/commit/29a5837c29620e33857d7a5afce01384e3f8e4... Patch
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Severity
7.6
High
Type
CWE-190Integer Overflow
Timeline
Published14 Jan 2023
Updated25 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta