Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2022-1435: The WPCargo Track & Trace WordPress plugin before 6.9.5 does not sanitize and escapes some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting atta...
CVE-2022-1435 · published 4 years ago
Summary
The WPCargo Track & Trace WordPress plugin before 6.9.5 does not sanitize and escapes some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.
What to do
- Update wptaskforce track_\&_trace to version 6.9.5 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wptaskforce | track_\&_trace |
< 6.9.5 cpe:2.3:a:wptaskforce:track_\&_trace:*:*:*:*:*:wordpress:*:* |
Original advisory text
The WPCargo Track & Trace WordPress plugin before 6.9.5 does not sanitize and escapes some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting atta...
The WPCargo Track & Trace WordPress plugin before 6.9.5 does not sanitize and escapes some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.
References
- https://wpscan.com/vulnerability/ef5aa8a7-23a7-4ce0-bb09-d9c986386114 Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published16 May 2022
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2022-1435 · NVD
Track software like this
Free during beta