Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.7

CVE-2022-1432: OctoPrint web page can run malicious code

CVE-2022-1432 · published 4 years ago
Summary

The OctoPrint web interface may allow attackers to insert harmful scripts that run in a user's browser. This could let them steal login details or change settings without permission. Update OctoPrint to version 1.8.0 or later, or apply the provided patches, to stop this risk.

What to do
  • Update gina häußge octoprint to version 1.8.0.
  • Update octoprint octoprint to version 1.8.0 or later.
Affected software
Ecosystem VendorProductAffected versions
pip gina häußge octoprint < 1.8.0
Fix: upgrade to 1.8.0
– octoprint octoprint < 1.8.0
cpe:2.3:a:octoprint:octoprint:*:*:*:*:*:*:*:*
Original advisory text
Cross-site Scripting (XSS) - Generic in octoprint/octoprint
Cross-site Scripting (XSS) - Generic in GitHub repository octoprint/octoprint prior to 1.8.0.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker full control (estimated)
Severity
7.7 High
Exploitation
1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published18 May 2022
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2022-1432 · NVD
CVE-2022-1432 · OSV
Track software like this
Free during beta