Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.8
CVE-2022-1391: The Cab fare calculator WordPress plugin before 1.0.4 does not validate the controller parameter before using it in require statements, which could lead to Local File Inclusion issues.
CVE-2022-1391 · published 4 years ago
Summary
The Cab fare calculator WordPress plugin before 1.0.4 does not validate the controller parameter before using it in require statements, which could lead to Local File Inclusion issues.
What to do
- Update kanev cab_fare_calculator to version 1.0.4 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| kanev | cab_fare_calculator |
< 1.0.4 cpe:2.3:a:kanev:cab_fare_calculator:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Cab fare calculator WordPress plugin before 1.0.4 does not validate the controller parameter before using it in require statements, which could lead to Local File Inclusion issues.
The Cab fare calculator WordPress plugin before 1.0.4 does not validate the controller parameter before using it in require statements, which could lead to Local File Inclusion issues.
References
- https://packetstormsecurity.com/files/166533/ Exploit Third Party Advisory VDB Entry
- https://wpscan.com/vulnerability/680121fe-6668-4c1a-a30d-e70dd9be5aac Exploit Third Party Advisory
Internet-facing
3 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker full control (estimated)
Type
CWE-22Path Traversal
Timeline
Published25 Apr 2022
Updated22 Oct 2026
First seen29 Sep 2026
Sources
CVE-2022-1391 · NVD
Track software like this
Free during beta