Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.3

CVE-2022-0574: Publify versions before 9.2.8 allow unauthorized access

CVE-2022-0574 · published 4 years ago
Summary

The core Publify software and the Publify project can let people see or change data they shouldn’t be able to when running versions older than 9.2.8. This could expose confidential information or let attackers modify content. Upgrade to version 9.2.8 or later to close the gap.

What to do
  • Update matijs van zuijlen publify_core to version 9.2.8.
  • Update publify_project publify to version 9.2.8 or later.
Affected software
Ecosystem VendorProductAffected versions
rubygems matijs van zuijlen publify_core < 9.2.8
Fix: upgrade to 9.2.8
– publify_project publify < 9.2.8
cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:*
Original advisory text
Improper Access Control in publify/publify
Improper Access Control in GitHub repository publify/publify prior to 9.2.8.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
5.3 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-863Incorrect Authorization
CWE-284Improper Access Control
Timeline
Published16 May 2022
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2022-0574 · NVD
CVE-2022-0574 · OSV
Track software like this
Free during beta