Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2022-0402: Superforms < 6.0.4 - Reflected Cross-Site Scripting

CVE-2022-0402 · published 2 years ago
Summary

The Super Forms - Drag & Drop Form Builder WordPress plugin before 6.0.4 does not escape the bob_czy_panstwa_sprawa_zostala_rozwiazana parameter before outputting it back in an attribute via the super_language_switcher AJAX action, leading to a Reflected Cross-Site Scripting. The action is also lack...

What to do
  • Update super-forms super_forms to version 6.0.4 or later.
Affected software
VendorProductAffected versions
super-forms super_forms < 6.0.4
cpe:2.3:a:super-forms:super_forms:*:*:*:*:*:wordpress:*:*
Original advisory text
Superforms < 6.0.4 - Reflected Cross-Site Scripting
The Super Forms - Drag & Drop Form Builder WordPress plugin before 6.0.4 does not escape the bob_czy_panstwa_sprawa_zostala_rozwiazana parameter before outputting it back in an attribute via the super_language_switcher AJAX action, leading to a Reflected Cross-Site Scripting. The action is also lacking CSRF, making the attack easier to perform against any user.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.1 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published16 Jan 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2022-0402 · NVD
CVE-2022-0402 · OSV
Track software like this
Free during beta