Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2022-0208: The MapPress Maps for WordPress plugin before 2.73.4 does not sanitise and escape the mapid parameter before outputting it back in the "Bad mapid" error message, leading to a Reflected Cross-Site S...
CVE-2022-0208 · published 4 years ago
Summary
The MapPress Maps for WordPress plugin before 2.73.4 does not sanitise and escape the mapid parameter before outputting it back in the "Bad mapid" error message, leading to a Reflected Cross-Site Scripting
What to do
- Update mappresspro mappress to version 2.73.4 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| mappresspro | mappress |
< 2.73.4 cpe:2.3:a:mappresspro:mappress:*:*:*:*:*:wordpress:*:* |
Original advisory text
The MapPress Maps for WordPress plugin before 2.73.4 does not sanitise and escape the mapid parameter before outputting it back in the "Bad mapid" error message, leading to a Reflected Cross-Site S...
The MapPress Maps for WordPress plugin before 2.73.4 does not sanitise and escape the mapid parameter before outputting it back in the "Bad mapid" error message, leading to a Reflected Cross-Site Scripting
References
- https://wpscan.com/vulnerability/59a2abd0-4aee-47aa-ad3a-865f624fa0fc Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published14 Feb 2022
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2022-0208 · NVD
Track software like this
Free during beta