Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.3
CVE-2021-43857: Gerapy Remote Code Execution in Versions Prior to 0.9.8
CVE-2021-43857 · published 4 years ago
Summary
Gerapy's distributed crawler management framework has a security weakness in older versions. This means an attacker could potentially execute malicious code on your system if they exploit this issue. Update to version 0.9.8 or later to fix the issue.
What to do
- Update germey gerapy to version 0.9.8.
- Update gerapy gerapy to version 0.9.8 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| pip | germey | gerapy |
< 0.9.8 Fix: upgrade to 0.9.8
|
| – | gerapy | gerapy |
< 0.9.8 cpe:2.3:a:gerapy:gerapy:*:*:*:*:*:*:*:* |
Original advisory text
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
References
- https://github.com/Gerapy/Gerapy/security/advisories/GHSA-9w7f-m4j4-j3xw
- https://nvd.nist.gov/vuln/detail/CVE-2021-43857
- https://github.com/Gerapy/Gerapy/issues/219
- https://github.com/Gerapy/Gerapy/commit/49bcb19be5e0320e7e1535f34fe00f16a3cf3b28
- http://packetstormsecurity.com/files/165459/Gerapy-0.9.7-Remote-Code-Execution.h...
- https://github.com/pypa/advisory-database/tree/main/vulns/gerapy/PYSEC-2022-228....
- https://github.com/pypa/advisory-database/tree/main/vulns/gerapy/PYSEC-2021-867....
- https://github.com/advisories/GHSA-9w7f-m4j4-j3xw
Internet-facing
3 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker full control (estimated)
Type
CWE-78OS Command Injection
Timeline
Published27 Dec 2021
Updated25 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta