Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2021-43527: NSS (Network Security Services) versions prior to 3.73 or 3.68.1 ESR are vulnerable to a heap overflow when handling DER-encoded DSA or RSA-PSS signatures. Applications using NSS for handling signa...

CVE-2021-43527 · published 4 years ago
Summary

NSS (Network Security Services) versions prior to 3.73 or 3.68.1 ESR are vulnerable to a heap overflow when handling DER-encoded DSA or RSA-PSS signatures. Applications using NSS for handling signatures encoded within CMS, S/MIME, PKCS \#7, or PKCS \#12 are likely to be impacted. Applications using ...

What to do
  • Update mozilla nss to version 3.73 or later.
  • Update mozilla nss_esr to version 3.68.1 or later.
Affected software
VendorProductAffected versions
mozilla nss < 3.73
cpe:2.3:a:mozilla:nss:*:*:*:*:*:*:*:*
mozilla nss_esr < 3.68.1
cpe:2.3:a:mozilla:nss_esr:*:*:*:*:*:*:*:*
netapp cloud_backup All versions
cpe:2.3:a:netapp:cloud_backup:-:*:*:*:*:*:*:*
netapp e-series_santricity_os_controller >= 11.0, <= 11.70.1
cpe:2.3:a:netapp:e-series_santricity_os_controller:*:*:*:*:*:*:*:*
oracle communications_cloud_native_core_binding_support_function 1.11.0
cpe:2.3:a:oracle:communications_cloud_native_core_binding_support_function:1.11.0:*:*:*:*:*:*:*
oracle communications_cloud_native_core_network_repository_function 1.15.0
1.15.1
cpe:2.3:a:oracle:communications_cloud_native_core_network_repository_function:1.15.0:*:*:*:*:*:*:*
oracle communications_cloud_native_core_network_slice_selection_function 1.8.0
cpe:2.3:a:oracle:communications_cloud_native_core_network_slice_selection_function:1.8.0:*:*:*:*:*:*:*
oracle communications_policy_management 12.6.0.0.0
cpe:2.3:a:oracle:communications_policy_management:12.6.0.0.0:*:*:*:*:*:*:*
starwindsoftware starwind_san_\&_nas v8r13
cpe:2.3:a:starwindsoftware:starwind_san_\&_nas:v8r13:*:*:*:*:*:*:*
starwindsoftware starwind_virtual_san v8r13
cpe:2.3:a:starwindsoftware:starwind_virtual_san:v8r13:14398:*:*:*:*:*:*
Original advisory text
NSS (Network Security Services) versions prior to 3.73 or 3.68.1 ESR are vulnerable to a heap overflow when handling DER-encoded DSA or RSA-PSS signatures. Applications using NSS for handling signa...
NSS (Network Security Services) versions prior to 3.73 or 3.68.1 ESR are vulnerable to a heap overflow when handling DER-encoded DSA or RSA-PSS signatures. Applications using NSS for handling signatures encoded within CMS, S/MIME, PKCS \#7, or PKCS \#12 are likely to be impacted. Applications using NSS for certificate validation or other TLS, X.509, OCSP or CRL functionality may be impacted, depending on how they configure NSS. *Note: This vulnerability does NOT impact Mozilla Firefox.* However, email clients and PDF viewers that use NSS for signature verification, such as Thunderbird, LibreOffice, Evolution and Evince are believed to be impacted. This vulnerability affects NSS < 3.73 and NSS < 3.68.1.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
9.8 Critical
Exploitation
18% chance of attack within 30 days
Type
CWE-787Out-of-bounds Write
Timeline
Published8 Dec 2021
Updated3 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta