Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.0

CVE-2021-43414: An issue was discovered in GNU Hurd before 0.9 20210404-9. The use of an authentication protocol in the proc server is vulnerable to man-in-the-middle attacks, which can be exploited for local priv...

CVE-2021-43414 · published 4 years ago
Summary

An issue was discovered in GNU Hurd before 0.9 20210404-9. The use of an authentication protocol in the proc server is vulnerable to man-in-the-middle attacks, which can be exploited for local privilege escalation to get full root access.

What to do
  • Update gnu hurd to version 0.9.20210404-9 or later.
Affected software
VendorProductAffected versions
gnu hurd < 0.9.20210404-9
cpe:2.3:a:gnu:hurd:*:*:*:*:*:*:*:*
Original advisory text
An issue was discovered in GNU Hurd before 0.9 20210404-9. The use of an authentication protocol in the proc server is vulnerable to man-in-the-middle attacks, which can be exploited for local priv...
An issue was discovered in GNU Hurd before 0.9 20210404-9. The use of an authentication protocol in the proc server is vulnerable to man-in-the-middle attacks, which can be exploited for local privilege escalation to get full root access.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker full control (estimated)
Severity
7.0 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-287Improper Authentication
Timeline
Published7 Nov 2021
Updated3 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta