Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2021-42129: A command injection vulnerability exists in Ivanti Avalanche before 6.3.3 allows an attacker with access to the Inforail Service to perform arbitrary command execution.
CVE-2021-42129 · published 4 years ago
Summary
A command injection vulnerability exists in Ivanti Avalanche before 6.3.3 allows an attacker with access to the Inforail Service to perform arbitrary command execution.
What to do
- Update ivanti avalanche to version 6.3.3 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| ivanti | avalanche |
< 6.3.3 cpe:2.3:a:ivanti:avalanche:*:*:*:*:*:*:*:* |
Original advisory text
A command injection vulnerability exists in Ivanti Avalanche before 6.3.3 allows an attacker with access to the Inforail Service to perform arbitrary command execution.
A command injection vulnerability exists in Ivanti Avalanche before 6.3.3 allows an attacker with access to the Inforail Service to perform arbitrary command execution.
References
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-77Command Injection
Timeline
Published7 Dec 2021
Updated29 Sep 2026
First seen29 Sep 2026
Sources
CVE-2021-42129 · NVD
Track software like this
Free during beta