Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2021-41020: An improper access control vulnerability [CWE-284] in FortiIsolator versions 2.3.2 and below may allow an authenticated, non privileged attacker to regenerate the CA certificate via the regeneratio...
CVE-2021-41020 · published 4 years ago
Summary
An improper access control vulnerability [CWE-284] in FortiIsolator versions 2.3.2 and below may allow an authenticated, non privileged attacker to regenerate the CA certificate via the regeneration URL.
What to do
- Update fortinet fortiisolator to version 2.3.3 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| fortinet | fortiisolator |
>= 2.3.0, < 2.3.3 cpe:2.3:a:fortinet:fortiisolator:*:*:*:*:*:*:*:* |
Original advisory text
An improper access control vulnerability [CWE-284] in FortiIsolator versions 2.3.2 and below may allow an authenticated, non privileged attacker to regenerate the CA certificate via the regeneratio...
An improper access control vulnerability [CWE-284] in FortiIsolator versions 2.3.2 and below may allow an authenticated, non privileged attacker to regenerate the CA certificate via the regeneration URL.
References
- https://fortiguard.com/psirt/FG-IR-21-040 Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Timeline
Published4 May 2022
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2021-41020 · NVD
Track software like this
Free during beta