Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.3
CVE-2021-40720: Ops CLI versions 2.0.4 and earlier: Malicious file can run code on your computer
CVE-2021-40720 · published 5 years ago
Summary
If you use Ops CLI, an attacker can create a malicious file that can execute code on your computer if you call the checkout_repo function. This can happen if you run a compromised file. Update to the latest version of Ops CLI to fix this issue.
What to do
- Update adobe ops-cli to version 2.0.5.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| pip | adobe | ops-cli |
<= 2.0.4 Fix: upgrade to 2.0.5
|
| – | adobe | ops-cli |
< 2.0.5 cpe:2.3:a:adobe:ops-cli:*:*:*:*:*:*:*:* |
Original advisory text
Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the checkout_repo function is called on a maliciously c...
Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the checkout_repo function is called on a maliciously crafted file. An attacker can leverage this to execute arbitrary code on the victim machine.
Internet-facing
3 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker full control (estimated)
Type
CWE-502Deserialization of Untrusted Data
Timeline
Published15 Oct 2021
Updated15 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta