Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.8

CVE-2021-35955: Contao Backend Cross-Site Scripting through HTML Attributes

CVE-2021-35955 · published 5 years ago
Summary

A security issue in Contao allows attackers to inject malicious code into the backend of websites built with Contao. This can lead to unauthorized actions or data theft. Update to a fixed version of Contao, such as 4.4.56, 4.9.18, or 4.11.7.

What to do
  • Update contao core-bundle to version 4.4.56.
  • Update contao contao to version 4.4.56.
  • Update contao contao to version 4.9.18.
  • Update contao contao to version 4.11.7.
  • Update contao core-bundle to version 4.9.18.
  • Update contao core-bundle to version 4.11.7.
Affected software
Ecosystem VendorProductAffected versions
composer contao core-bundle >= 4.0.0, < 4.4.56
>= 4.5.0, < 4.9.18
>= 4.10.0, < 4.11.7
Fix: upgrade to 4.4.56
composer contao contao >= 4.0.0, < 4.4.56
>= 4.5.0, < 4.9.18
>= 4.10.0, < 4.11.7
Fix: upgrade to 4.4.56
Original advisory text
Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.
Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.8 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published12 Aug 2021
Updated4 Nov 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta