Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2021-34815: CheckSec Canopy before 3.5.2 allows XSS attacks against the login page via the LOGIN_PAGE_DISCLAIMER parameter.
CVE-2021-34815 · published 5 years ago
Summary
CheckSec Canopy before 3.5.2 allows XSS attacks against the login page via the LOGIN_PAGE_DISCLAIMER parameter.
What to do
- Update checksec canopy to version 3.5.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| checksec | canopy |
< 3.5.2 cpe:2.3:a:checksec:canopy:*:*:*:*:*:*:*:* |
Original advisory text
CheckSec Canopy before 3.5.2 allows XSS attacks against the login page via the LOGIN_PAGE_DISCLAIMER parameter.
CheckSec Canopy before 3.5.2 allows XSS attacks against the login page via the LOGIN_PAGE_DISCLAIMER parameter.
References
- https://www.checksec.com/canopy.html Product
- https://www.compass-security.com/en/research/advisories Third Party Advisory
- https://www.compass-security.com/fileadmin/Research/Advisories/2021-10_CSNC-2021... Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published18 Jun 2021
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2021-34815 · NVD
Track software like this
Free during beta