Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
2.0
CVE-2021-29618: TensorFlow Crashes When Using Certain Machine Learning Function
CVE-2021-29618 · published 5 years ago
Summary
TensorFlow's machine learning platform crashes when a complex argument is passed to a specific function in a particular way. This can cause the software to stop working unexpectedly, which can disrupt business operations. Affected users should update to the latest version of TensorFlow to prevent crashes.
What to do
- Update google inc. tensorflow to version 2.1.4.
- Update google inc. tensorflow to version 2.2.3.
- Update google inc. tensorflow to version 2.3.3.
- Update google inc. tensorflow to version 2.4.2.
- Update google tensorflow-gpu to version 2.1.4.
- Update google tensorflow-gpu to version 2.2.3.
- Update google tensorflow-gpu to version 2.3.3.
- Update google tensorflow-gpu to version 2.4.2.
- Update google inc. tensorflow-cpu to version 2.1.4.
- Update google inc. tensorflow-cpu to version 2.2.3.
- Update google inc. tensorflow-cpu to version 2.3.3.
- Update google inc. tensorflow-cpu to version 2.4.2.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| pip | google inc. | tensorflow |
< 2.1.4 >= 2.2.0, < 2.2.3 >= 2.3.0, < 2.3.3 >= 2.4.0, < 2.4.2 Fix: upgrade to 2.1.4
|
| pip | tensorflow-gpu |
< 2.1.4 >= 2.2.0, < 2.2.3 >= 2.3.0, < 2.3.3 >= 2.4.0, < 2.4.2 Fix: upgrade to 2.1.4
|
|
| pip | google inc. | tensorflow-cpu |
< 2.1.4 >= 2.2.0, < 2.2.3 >= 2.3.0, < 2.3.3 >= 2.4.0, < 2.4.2 Fix: upgrade to 2.1.4
|
| – | tensorflow |
< 2.1.4 >= 2.2.0, < 2.2.3 >= 2.3.0, < 2.3.3 >= 2.4.0, < 2.4.2 cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* |
Original advisory text
TensorFlow is an end-to-end open source platform for machine learning. Passing a complex argument to `tf.transpose` at the same time as passing `conjugate=True` argument results in a crash. The fix...
TensorFlow is an end-to-end open source platform for machine learning. Passing a complex argument to `tf.transpose` at the same time as passing `conjugate=True` argument results in a crash. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xqfj-cr6q-pc8w
- https://nvd.nist.gov/vuln/detail/CVE-2021-29618
- https://github.com/tensorflow/tensorflow/commit/1dc6a7ce6e0b3e27a7ae650bfc05b195...
- https://github.com/tensorflow/issues/42105
- https://github.com/tensorflow/issues/46973
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2...
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2...
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-...
- https://github.com/advisories/GHSA-xqfj-cr6q-pc8w
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-755Improper Handling of Exceptional Conditions
Timeline
Published14 May 2021
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta