Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
2.0
CVE-2021-29575: TensorFlow's Machine Learning Platform Can Be Crashed by Malicious Input
CVE-2021-29575 · published 5 years ago
Summary
TensorFlow's machine learning platform can be crashed by malicious input, potentially causing it to stop working. This issue affects users of TensorFlow versions 2.1, 2.2, 2.3, 2.4, and 2.5. To fix the issue, users should upgrade to TensorFlow 2.5.0 or apply a patch to versions 2.1.4, 2.2.3, 2.3.3, 2.4.2.
What to do
- Update google inc. tensorflow to version 2.1.4.
- Update google inc. tensorflow to version 2.2.3.
- Update google inc. tensorflow to version 2.3.3.
- Update google inc. tensorflow to version 2.4.2.
- Update google tensorflow-gpu to version 2.1.4.
- Update google tensorflow-gpu to version 2.2.3.
- Update google tensorflow-gpu to version 2.3.3.
- Update google tensorflow-gpu to version 2.4.2.
- Update google inc. tensorflow-cpu to version 2.1.4.
- Update google inc. tensorflow-cpu to version 2.2.3.
- Update google inc. tensorflow-cpu to version 2.3.3.
- Update google inc. tensorflow-cpu to version 2.4.2.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| pip | google inc. | tensorflow |
< 2.1.4 >= 2.2.0, < 2.2.3 >= 2.3.0, < 2.3.3 >= 2.4.0, < 2.4.2 Fix: upgrade to 2.1.4
|
| pip | tensorflow-gpu |
< 2.1.4 >= 2.2.0, < 2.2.3 >= 2.3.0, < 2.3.3 >= 2.4.0, < 2.4.2 Fix: upgrade to 2.1.4
|
|
| pip | google inc. | tensorflow-cpu |
< 2.1.4 >= 2.2.0, < 2.2.3 >= 2.3.0, < 2.3.3 >= 2.4.0, < 2.4.2 Fix: upgrade to 2.1.4
|
| – | tensorflow |
<= 2.1.4 >= 2.2.0, < 2.2.3 >= 2.3.0, < 2.3.3 >= 2.4.0, < 2.4.2 cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* |
Original advisory text
TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.ReverseSequence` allows for stack overflow and/or `CHECK`-fail based denial of service. The ...
TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.ReverseSequence` allows for stack overflow and/or `CHECK`-fail based denial of service. The implementation(https://github.com/tensorflow/tensorflow/blob/5b3b071975e01f0d250c928b2a8f901cd53b90a7/tensorflow/core/kernels/reverse_sequence_op.cc#L114-L118) fails to validate that `seq_dim` and `batch_dim` arguments are valid. Negative values for `seq_dim` can result in stack overflow or `CHECK`-failure, depending on the version of Eigen code used to implement the operation. Similar behavior can be exhibited by invalid values of `batch_dim`. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-6qgm-fv6v-rfpv
- https://nvd.nist.gov/vuln/detail/CVE-2021-29575
- https://github.com/tensorflow/tensorflow/commit/ecf768cbe50cedc0a45ce1ee223146a3...
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2...
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2...
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-...
- https://github.com/advisories/GHSA-6qgm-fv6v-rfpv
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-119Buffer Overflow
CWE-120Classic Buffer Overflow
CWE-787Out-of-bounds Write
Timeline
Published14 May 2021
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta