Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.7

CVE-2021-27923: Pillow library can let attackers run code

CVE-2021-27923 · published today
Summary

The Python Pillow image library used in many applications has a flaw that could allow a malicious user to execute unwanted commands on your system. This matters because it could let attackers compromise servers or data. Update Pillow to the latest released version to close the risk.

What to do
  • Update jeffrey 'alex' clark pillow to version 8.1.2.
  • Update pillow to version 8.0.1+aikido.1.
  • Update pillow to version 8.0.1+aikido.2.
  • Update pillow to version 7.0.0+aikido.2.
  • Update python pillow to version 8.1.1 or later.
Affected software
Ecosystem VendorProductAffected versions
pip jeffrey 'alex' clark pillow < 8.1.2
Fix: upgrade to 8.1.2
– python pillow < 8.1.1
cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:*
– fedoraproject fedora 32
33
34
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*
Root:PyPI – pillow < 8.0.1+aikido.1
< 8.0.1+aikido.2
< 7.0.0+aikido.2
Fix: upgrade to 8.0.1+aikido.1
Original advisory text
CVE-2021-27923 in pillow - Patched by Root
Root has patched CVE-2021-27923 in the pillow package for Root:PyPI. Multiple fixed versions available.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
8.7 High
Exploitation
3% chance of attack within 30 days
Type
CWE-20Improper Input Validation
CWE-400Uncontrolled Resource Consumption
Timeline
Published4 Nov 2026
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta