Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2021-27239: This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6400 and R6700 firmware version 1.0.4.98 routers. Authentication is not required...
CVE-2021-27239 · published 5 years ago
Summary
This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6400 and R6700 firmware version 1.0.4.98 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the upnpd service, which listens on UDP...
What to do
- Update netgear d6220_firmware to version 1.0.0.68 or later.
- Update netgear d6400_firmware to version 1.0.0.102 or later.
- Update netgear d7000_firmware to version 1.0.0.66 or later.
- Update netgear d8500_firmware to version 1.0.3.60 or later.
- Update netgear dc112a_firmware to version 1.0.0.54 or later.
- Update netgear ex7000_firmware to version 1.0.1.94 or later.
- Update netgear ex7500_firmware to version 1.0.0.72 or later.
- Update netgear r6250_firmware to version 1.0.4.48 or later.
- Update netgear r6300_firmware to version 1.0.4.50 or later.
- Update netgear r6700_firmware to version 1.0.4.102 or later.
- Update netgear r6900p_firmware to version 1.3.2.132 or later.
- Update netgear r7000_firmware to version 1.0.11.116 or later.
- Update netgear r7000p_firmware to version 1.3.2.132 or later.
- Update netgear r7100lg_firmware to version 1.0.0.64 or later.
- Update netgear r7850_firmware to version 1.0.5.68 or later.
- Update netgear r7900_firmware to version 1.0.4.38 or later.
- Update netgear r7900p_firmware to version 1.4.1.68 or later.
- Update netgear r7960p_firmware to version 1.4.1.68 or later.
- Update netgear r8000_firmware to version 1.0.4.68 or later.
- Update netgear r8000p_firmware to version 1.4.1.68 or later.
- Update netgear r8300_firmware to version 1.0.2.144 or later.
- Update netgear r8500_firmware to version 1.0.2.144 or later.
- Update netgear rax200_firmware to version 1.0.2.88 or later.
- Update netgear rax75_firmware to version 1.0.3.102 or later.
- Update netgear rax80_firmware to version 1.0.3.102 or later.
- Update netgear rbr750_firmware to version 3.2.17.12 or later.
- Update netgear rbr850_firmware to version 3.2.17.12 or later.
- Update netgear rbs40v_firmware to version 2.6.2.4 or later.
- Update netgear rbs750_firmware to version 3.2.17.12 or later.
- Update netgear rbs850_firmware to version 3.2.17.12 or later.
- Update netgear wndr3400_firmware to version 1.0.1.38 or later.
- Update netgear wnr3500l_firmware to version 1.2.0.66 or later.
- Update netgear xr300_firmware to version 1.0.3.56 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| netgear | d6220_firmware |
< 1.0.0.68 cpe:2.3:o:netgear:d6220_firmware:*:*:*:*:*:*:*:* |
| netgear | d6400_firmware |
< 1.0.0.102 cpe:2.3:o:netgear:d6400_firmware:*:*:*:*:*:*:*:* |
| netgear | d7000_firmware |
< 1.0.0.66 cpe:2.3:o:netgear:d7000_firmware:*:*:*:*:*:*:*:* |
| netgear | d8500_firmware |
< 1.0.3.60 cpe:2.3:o:netgear:d8500_firmware:*:*:*:*:*:*:*:* |
| netgear | dc112a_firmware |
< 1.0.0.54 cpe:2.3:o:netgear:dc112a_firmware:*:*:*:*:*:*:*:* |
| netgear | ex7000_firmware |
< 1.0.1.94 cpe:2.3:o:netgear:ex7000_firmware:*:*:*:*:*:*:*:* |
| netgear | ex7500_firmware |
< 1.0.0.72 cpe:2.3:o:netgear:ex7500_firmware:*:*:*:*:*:*:*:* |
| netgear | r6250_firmware |
< 1.0.4.48 cpe:2.3:o:netgear:r6250_firmware:*:*:*:*:*:*:*:* |
| netgear | r6300_firmware |
< 1.0.4.50 cpe:2.3:o:netgear:r6300_firmware:*:*:*:*:*:*:*:* |
| netgear | r6400_firmware |
< 1.0.1.68 < 1.0.4.102 cpe:2.3:o:netgear:r6400_firmware:*:*:*:*:*:*:*:* |
| netgear | r6700_firmware |
< 1.0.4.102 cpe:2.3:o:netgear:r6700_firmware:*:*:*:*:*:*:*:* |
| netgear | r6900p_firmware |
< 1.3.2.132 cpe:2.3:o:netgear:r6900p_firmware:*:*:*:*:*:*:*:* |
| netgear | r7000_firmware |
< 1.0.11.116 cpe:2.3:o:netgear:r7000_firmware:*:*:*:*:*:*:*:* |
| netgear | r7000p_firmware |
< 1.3.2.132 cpe:2.3:o:netgear:r7000p_firmware:*:*:*:*:*:*:*:* |
| netgear | r7100lg_firmware |
< 1.0.0.64 cpe:2.3:o:netgear:r7100lg_firmware:*:*:*:*:*:*:*:* |
| netgear | r7850_firmware |
< 1.0.5.68 cpe:2.3:o:netgear:r7850_firmware:*:*:*:*:*:*:*:* |
| netgear | r7900_firmware |
< 1.0.4.38 cpe:2.3:o:netgear:r7900_firmware:*:*:*:*:*:*:*:* |
| netgear | r7900p_firmware |
< 1.4.1.68 cpe:2.3:o:netgear:r7900p_firmware:*:*:*:*:*:*:*:* |
| netgear | r7960p_firmware |
< 1.4.1.68 cpe:2.3:o:netgear:r7960p_firmware:*:*:*:*:*:*:*:* |
| netgear | r8000_firmware |
< 1.0.4.68 cpe:2.3:o:netgear:r8000_firmware:*:*:*:*:*:*:*:* |
| netgear | r8000p_firmware |
< 1.4.1.68 cpe:2.3:o:netgear:r8000p_firmware:*:*:*:*:*:*:*:* |
| netgear | r8300_firmware |
< 1.0.2.144 cpe:2.3:o:netgear:r8300_firmware:*:*:*:*:*:*:*:* |
| netgear | r8500_firmware |
< 1.0.2.144 cpe:2.3:o:netgear:r8500_firmware:*:*:*:*:*:*:*:* |
| netgear | rax200_firmware |
< 1.0.2.88 cpe:2.3:o:netgear:rax200_firmware:*:*:*:*:*:*:*:* |
| netgear | rax75_firmware |
< 1.0.3.102 cpe:2.3:o:netgear:rax75_firmware:*:*:*:*:*:*:*:* |
| netgear | rax80_firmware |
< 1.0.3.102 cpe:2.3:o:netgear:rax80_firmware:*:*:*:*:*:*:*:* |
| netgear | rbr750_firmware |
< 3.2.17.12 cpe:2.3:o:netgear:rbr750_firmware:*:*:*:*:*:*:*:* |
| netgear | rbr850_firmware |
< 3.2.17.12 cpe:2.3:o:netgear:rbr850_firmware:*:*:*:*:*:*:*:* |
| netgear | rbs40v_firmware |
< 2.6.2.4 cpe:2.3:o:netgear:rbs40v_firmware:*:*:*:*:*:*:*:* |
| netgear | rbs750_firmware |
< 3.2.17.12 cpe:2.3:o:netgear:rbs750_firmware:*:*:*:*:*:*:*:* |
| netgear | rbs850_firmware |
< 3.2.17.12 cpe:2.3:o:netgear:rbs850_firmware:*:*:*:*:*:*:*:* |
| netgear | rs400_firmware |
<= 1.5.0.68 cpe:2.3:o:netgear:rs400_firmware:*:*:*:*:*:*:*:* |
| netgear | wndr3400_firmware |
< 1.0.1.38 cpe:2.3:o:netgear:wndr3400_firmware:*:*:*:*:*:*:*:* |
| netgear | wnr3500l_firmware |
< 1.2.0.66 cpe:2.3:o:netgear:wnr3500l_firmware:*:*:*:*:*:*:*:* |
| netgear | xr300_firmware |
< 1.0.3.56 cpe:2.3:o:netgear:xr300_firmware:*:*:*:*:*:*:*:* |
Original advisory text
This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6400 and R6700 firmware version 1.0.4.98 routers. Authentication is not required...
This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6400 and R6700 firmware version 1.0.4.98 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the upnpd service, which listens on UDP port 1900 by default. A crafted MX header field in an SSDP message can trigger an overflow of a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-11851.
References
- https://kb.netgear.com/000062820/Security-Advisory-for-Stack-based-Buffer-Overfl... Vendor Advisory
- https://www.zerodayinitiative.com/advisories/ZDI-21-206/ Third Party Advisory VDB Entry
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-121Stack-based Buffer Overflow
Timeline
Published29 Mar 2021
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2021-27239 · NVD
Track software like this
Free during beta