Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2021-24637: The Google Fonts Typography WordPress plugin before 3.0.3 does not escape and sanitise some of its block settings, allowing users with as role as low as Contributor to perform Stored Cross-Site Scr...
CVE-2021-24637 · published 5 years ago
Summary
The Google Fonts Typography WordPress plugin before 3.0.3 does not escape and sanitise some of its block settings, allowing users with as role as low as Contributor to perform Stored Cross-Site Scripting attacks via blockType (combined with content), align, color, variant and fontID argument of a Gu...
What to do
- Update fontsplugin fonts to version 3.0.3 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| fontsplugin | fonts |
< 3.0.3 cpe:2.3:a:fontsplugin:fonts:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Google Fonts Typography WordPress plugin before 3.0.3 does not escape and sanitise some of its block settings, allowing users with as role as low as Contributor to perform Stored Cross-Site Scr...
The Google Fonts Typography WordPress plugin before 3.0.3 does not escape and sanitise some of its block settings, allowing users with as role as low as Contributor to perform Stored Cross-Site Scripting attacks via blockType (combined with content), align, color, variant and fontID argument of a Gutenberg block.
References
- https://wpscan.com/vulnerability/dd2b3f22-5e8b-41cf-bcb8-d2e673e1d21e Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published20 Sep 2021
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2021-24637 · NVD
Track software like this
Free during beta