Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2021-24381: The Ninja Forms Contact Form WordPress plugin before 3.5.8.2 does not sanitise and escape the custom class name of the form field created, which could allow high privilege users to perform Cross-Si...
CVE-2021-24381 · published 5 years ago
Summary
The Ninja Forms Contact Form WordPress plugin before 3.5.8.2 does not sanitise and escape the custom class name of the form field created, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
What to do
- Update ninjaforms contact_form to version 3.5.8.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| ninjaforms | contact_form |
< 3.5.8.2 cpe:2.3:a:ninjaforms:contact_form:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Ninja Forms Contact Form WordPress plugin before 3.5.8.2 does not sanitise and escape the custom class name of the form field created, which could allow high privilege users to perform Cross-Si...
The Ninja Forms Contact Form WordPress plugin before 3.5.8.2 does not sanitise and escape the custom class name of the form field created, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
References
- https://wpscan.com/vulnerability/e383fae6-e0da-4aba-bb62-adf51c01bf8d Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published25 Oct 2021
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2021-24381 · NVD
Track software like this
Free during beta