Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2021-23807: jsonpointer before 5.0.0: Type confusion can bypass security fix

CVE-2021-23807 · published 5 years ago
Summary

The jsonpointer package before version 5.0.0 has a security issue that can allow an attacker to bypass a previous security fix. This could potentially lead to unauthorized access to sensitive data. Update to version 5.0.0 or later to fix the issue.

What to do
  • Update marcbachmann jsonpointer to version 5.0.0.
  • Update org.webjars.npm:json-pointer to version 5.0.0.
  • Update janl jsonpointer to version 5.0.0 or later.
Affected software
Ecosystem VendorProductAffected versions
npm marcbachmann jsonpointer < 5.0.0
Fix: upgrade to 5.0.0
npm – org.webjars.npm:json-pointer < 5.0.0
Fix: upgrade to 5.0.0
– janl jsonpointer < 5.0.0
cpe:2.3:a:janl:jsonpointer:*:*:*:*:*:node.js:*:*
Original advisory text
This affects the package jsonpointer before 5.0.0. A type confusion vulnerability can lead to a bypass of a previous Prototype Pollution fix when the pointer components are arrays.
This affects the package jsonpointer before 5.0.0. A type confusion vulnerability can lead to a bypass of a previous Prototype Pollution fix when the pointer components are arrays.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
9.8 Critical
Exploitation
3% chance of attack within 30 days
Type
CWE-843Type Confusion
CWE-1321Prototype Pollution
Timeline
Published3 Nov 2021
Updated30 Oct 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta