Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2021-22658: Advantech iView versions prior to v5.7.03.6112 are vulnerable to a SQL injection, which may allow an attacker to escalate privileges to 'Administrator'.

CVE-2021-22658 · published 5 years ago
Summary

Advantech iView versions prior to v5.7.03.6112 are vulnerable to a SQL injection, which may allow an attacker to escalate privileges to 'Administrator'.

What to do
  • Update advantech iview to version 5.7.03.6112 or later.
Affected software
VendorProductAffected versions
advantech iview < 5.7.03.6112
cpe:2.3:a:advantech:iview:*:*:*:*:*:*:*:*
Original advisory text
Advantech iView versions prior to v5.7.03.6112 are vulnerable to a SQL injection, which may allow an attacker to escalate privileges to 'Administrator'.
Advantech iView versions prior to v5.7.03.6112 are vulnerable to a SQL injection, which may allow an attacker to escalate privileges to 'Administrator'.
References
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
9.8 Critical
Exploitation
13% chance of attack within 30 days
Type
CWE-89SQL Injection
Timeline
Published11 Feb 2021
Updated19 Oct 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta