Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2021-21327: GLPI versions before 9.5.4: Unauthenticated access to internal data

CVE-2021-21327 · published 5 years ago
Summary

An attacker can access and misuse internal data in GLPI, potentially causing harm to the system. This affects the integrity of the GLPI core and third-party plugins. To fix this issue, update to version 9.5.4 or later.

What to do
  • Update glpi-project glpi to version 9.5.4 or later.
Affected software
VendorProductAffected versions
glpi-project glpi < 9.5.4
cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*
Original advisory text
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 non-authenticated use...
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 non-authenticated user can remotely instantiate object of any class existing in the GLPI environment that can be used to carry out malicious attacks, or to start a “POP chain”. As an example of direct impact, this vulnerability affects integrity of the GLPI core platform and third-party plugins runtime misusing classes which implement some sensitive operations in their constructors or destructors. This is fixed in version 9.5.4.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
7.5 High
Exploitation
2% chance of attack within 30 days
Type
CWE-862Missing Authorization
CWE-470Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection')
Timeline
Published8 Mar 2021
Updated29 Oct 2026
First seen9 Jul 2026
Sources
CVE-2021-21327 · NVD
Track software like this
Free during beta