Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2020-7845: Spamsniper 5.0 ~ 5.2.7 contain a stack-based buffer overflow vulnerability caused by improper boundary checks when parsing MAIL FROM command. It leads remote attacker to execute arbitrary code via ...

CVE-2020-7845 · published 5 years ago
Summary

Spamsniper 5.0 ~ 5.2.7 contain a stack-based buffer overflow vulnerability caused by improper boundary checks when parsing MAIL FROM command. It leads remote attacker to execute arbitrary code via crafted packet.

What to do
  • Update jiransecurity spamsniper to version 5.7.6 or later.
Affected software
VendorProductAffected versions
jiransecurity spamsniper >= 5.0.2, < 5.7.6
cpe:2.3:a:jiransecurity:spamsniper:*:*:*:*:*:*:*:*
Original advisory text
Spamsniper 5.0 ~ 5.2.7 contain a stack-based buffer overflow vulnerability caused by improper boundary checks when parsing MAIL FROM command. It leads remote attacker to execute arbitrary code via ...
Spamsniper 5.0 ~ 5.2.7 contain a stack-based buffer overflow vulnerability caused by improper boundary checks when parsing MAIL FROM command. It leads remote attacker to execute arbitrary code via crafted packet.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
9.8 Critical
Exploitation
3% chance of attack within 30 days
Type
CWE-121Stack-based Buffer Overflow
CWE-787Out-of-bounds Write
Timeline
Published27 Dec 2020
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2020-7845 · NVD
Track software like this
Free during beta