Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.1

CVE-2020-36865: Nagios XI versions prior to 5.7.2 allow malicious code injection

CVE-2020-36865 · published 1 year ago
Summary

If you're using Nagios XI versions before 5.7.2, an attacker could potentially inject malicious code into your system through the Business Process Intelligence component's configuration settings. This could let them access sensitive information or take control of your system. Update to version 5.7.2 or later to fix this issue.

What to do
  • Update nagios nagios_xi to version 5.7.2 or later.
Affected software
VendorProductAffected versions
nagios nagios_xi < 5.7.2
cpe:2.3:a:nagios:nagios_xi:*:*:*:*:*:*:*:*
Original advisory text
Nagios XI versions prior to 5.7.2 are vulnerable to cross-site scripting (XSS) via the BPI (Business Process Intelligence) component’s Config Management and Edit Config page. Insufficient validatio...
Nagios XI versions prior to 5.7.2 are vulnerable to cross-site scripting (XSS) via the BPI (Business Process Intelligence) component’s Config Management and Edit Config page. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
5.1 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published30 Oct 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
Track software like this
Free during beta