Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2020-36636: A vulnerability classified as problematic has been found in OpenMRS Admin UI Module up to 1.4.x. Affected is the function sendErrorMessage of the file omod/src/main/java/org/openmrs/module/adminui/...
CVE-2020-36636 · published 3 years ago
Summary
A vulnerability classified as problematic has been found in OpenMRS Admin UI Module up to 1.4.x. Affected is the function sendErrorMessage of the file omod/src/main/java/org/openmrs/module/adminui/page/controller/systemadmin/accounts/AccountPageController.java of the component Account Setup Handler....
What to do
- Update openmrs admin_ui_module to version 1.5.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| openmrs | admin_ui_module |
< 1.5.0 cpe:2.3:a:openmrs:admin_ui_module:*:*:*:*:*:*:*:* |
Original advisory text
A vulnerability classified as problematic has been found in OpenMRS Admin UI Module up to 1.4.x. Affected is the function sendErrorMessage of the file omod/src/main/java/org/openmrs/module/adminui/...
A vulnerability classified as problematic has been found in OpenMRS Admin UI Module up to 1.4.x. Affected is the function sendErrorMessage of the file omod/src/main/java/org/openmrs/module/adminui/page/controller/systemadmin/accounts/AccountPageController.java of the component Account Setup Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 702fbfdac7c4418f23bb5f6452482b4a88020061. It is recommended to upgrade the affected component. VDB-216918 is the identifier assigned to this vulnerability.
References
- https://github.com/openmrs/openmrs-module-adminui/commit/702fbfdac7c4418f23bb5f6... Patch Third Party Advisory
- https://github.com/openmrs/openmrs-module-adminui/pull/57 Patch Third Party Advisory
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.5.0 Release Notes Third Party Advisory
- https://vuldb.com/?ctiid.216918 Permissions Required Third Party Advisory
- https://vuldb.com/?id.216918 Permissions Required Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published27 Dec 2022
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2020-36636 · NVD
Track software like this
Free during beta